主页 > 新闻 > eZ Publish 4.3.0 beta1 released

eZ Publish 4.3.0 beta1 released

 

众所瞩目的eZ Publish 4.3.0现在正式发布,这个版本包含了许多新的内建功能以及相关的扩充套件,程式除错与补强,和网站效能的提升。

Following the alpha1 release of eZ Publish we are happy to announce the beta1 release. It builds on the alpha1 and provides further bugfixes and adjustements.

Notable changes and improvements

  • Fixed an issue where class editing would make a class loose its group
  • Make sure that eZ JSCore is enabled by default
  • Several "loose" functions are deprecated
  • Deprecated classes have been removed
  • ezi18n() has been deprecated, so from now on calls to to the translation system from PHP code should go via ezpI18n::tr()
  • templateInit() has been deprecated, so from now on calls to to get template instance should go via ezTemplate::factory()
  • Important fix in the mysqli database handler, fixing a potential apache crash
  • Cache clearing scripts are now more strict, when being run by root.

For detailed changes see the changelogs below.

Known issues in this beta release

  • Currently eZ Publish will try to write a cache file into its var directory, before the setup wizard has been able to verify the file permissions, in order to avoid getting a warning message about this, the file permissions can be adjusted manually before starting the setup wizard, so that the web server has proper write permission on the var folder.

Notes on backwards compatibility

For more in-depth information on these changes have a look at the dedicated document for this: backwards compatibility information

Changelogs

Full changelog is available via the link: changelog 4.3.0alpha1 to 4.3.0beta1

Upgrading

We don't recommend upgrading any production site to eZ Publish 4.3.0beta1 yet. However if you want to give it a try in a testing environment, you need to replace the distribution files and run the two database upgrade scripts in noted below:

update/database/mysql|postgresql/4.3/unstable/dbupdate-4.2.0-to-4.3.0alpha1.sqlupdate/database/mysql|postgresql/4.3/unstable/dbupdate-4.3.0alpha1-to-4.3.0beta1.sql

In addition make sure to consult the documentation for any extension for specific instructions.